X and Y axis inverted [solved]

Discussion in 'Community Support' started by Erik de Bruijn, Jan 23, 2015.

  1. After assembling the Argentum to spec, we were able to get the jogs to work correctly after using "callibration". The callibration would occasionally hit endstops and motors would skip. After moving a square it would be done and you could jog X and it would actually move X. However we kept getting inconsistent results when it tried to print. It would bump into endstops without registering and we could only print by manually dragging the printhead through its steps and putting it somewhere away from the mechanical bounds of the printer.

    The image it would print had an XY inversion. Given that the two cartridges are side by side, moving the wrong axis would create a distorted printed...

    We've decided that there must be a way to fix it so we decided to try a few things. Eventually what worked was to remove the X motor plug and invert the wires (1, 2, 3, 4 became 4, 3, 2, 1) and we did the same for the Y motor. After changing this the calibration routine performed much better. And printing would trigger the endstops as expected. So we could finally print.

    So that is now SOLVED! On to the next challenge...

    The next hurdle is now that we're getting the "first circuit" print as two images, probably one by each of the cartridges. Apparently there needs to be another step in software which we didn't find? I'll write a separate thread if I find a new problem and/or solution.

    Attached Files:

Share This Page