Printing Issues (prev. Nozzle Testing hex file)

Discussion in 'Community Support' started by AdamF, Dec 15, 2014.

  1. I've loaded the hex file from http://wiki.cartesianco.com/Nozzle_Test onto the SD card and in the ArC console entering "p NozlTest.hex" and all I get from both silver and ascorbic cartridges, regardless which slot, is a double line about 3 inches long (see pic).

    I redid the FFC cables and they were fine, I reprimed the cartridges, cleaned them a bit with a kimwipe and alcohol, and got the same double line. I've also re-downloaded the hex and reloaded it using a different computer. None of the pogo pins appear bent or disturbed.

    Each number is a separate run. I think 3 and 4 are silver and the others ascorbic but it's hard to tell after the heatgun.
    console says "+File dimensions: 2676 x 0 steps"
    IMG_20141215_130846_722.jpg


    If it means anything, the reason I'm doing the test is because after printing 6+ layers of the starter circuit, I'm still having high resistance (1k+ in some traces) or no continuity at all. the traces look solid, if a bit fuzzy, but something's not working right.

    starter_circuit1.jpg

    It almost looks like one of them isn't coming out because mine seems much more 'burnt' than others' examples, but the nozzle tests showed both silver and acid doing the same thing regardless of carriage position. The camera makes it look much worse than it is. In reality it is more of a slate-green, or greyish-brown. hard to describe.
    Last edited: Dec 15, 2014
  2. Currently running a few alignment runs just for some more information, I'll post a picture here. Doesn't look promising, It seems like only a few of the nozzles are firing on both cartridges. Alignment looks all right, it's just very faded. I've cleaned them very thoroughly several times. I have access to an old ultrasonic cleaner, should I bother?

    alignmentPics.jpg
    These were done one after the other as numbered. The first and last are both with Vertical Offset at 0.
    Last edited: Dec 15, 2014
  3. Ariel

    Ariel Staff Member

    Hmmm, interesting. The nozzle test is the most concerning thing to me. It shouldn't look anything like what you're getting at all. Am I right to say the direction the heads are moving when it's printing is like this:

    IMG_20141215_130846_722.png
  4. Correct, it was printing left to right.
  5. Ariel

    Ariel Staff Member

    Oh well, that's just wrong! o_O

    So either something is going wrong with the software interpreting the hex file, or something is very wrong with the electronics.

    Electronics first: (because that's my part) there should be a sticker on your motherboard with a number, what is it? I can look up our testing records for it.
  6. 02-007
    v0.7.1, 30/04/14
  7. Michael Reed

    Michael Reed Staff Member

    Hey Ariel/AdamF - I believe this is a problem cropping up because of a recent change to the software/firmware. Previously in the code the horizontal axis was the y-axis which was just horribly confusing. Trent Waddington recently released firmware version 0_15_1.hex and an accompanying update on the software that flipped them back to correct (ie. right is pos. x axis and up is pos. y axis).

    Because the nozzle test isn't being re-generated with this in mind, the nozzle test hex code is actually 'incompatible' because it's axes are flipped.

    Quick solution for now: Load on 0_14.hex firmware and try the nozzle test again.
    Slightly longer solution: I can do a search/replace on the hex file to swap it back to correct and then re-upload it but I'm not in the office right now so that would have to wait until this afternoon (although you could of course do it yourself if you'd like).
  8. Ariel

    Ariel Staff Member

    Ah, that makes a lot of sense. I looked at the motherboard test records for 02-007 and everything showed fine.

    AdamF we'll let you know when we've fixed the test file.
  9. 0.14 fixed the nozzle issue. I'm going to retry the example circuit with .14. Hopefully the reason I was seeing such resistive traces with .15 is the same issue of only a few nozzles are firing because of their identity crisis

    I'm running software v0.15, I wont be able to generate a proper .hex, will I.
    Last edited: Dec 18, 2014
  10. Ariel

    Ariel Staff Member

    I'm not sure about being able to generate the appropriate hex file, I'll have to ask Trent if that's compatible.

    I'm interested in what your nozzle test print looked like when using .14 firmware though.
  11. Hey sorry, time zones and all that, was long gone from the office.
    The nozzle test worked okay, the image is with both cartridges in at the same time
    nozzleTest.jpg
  12. Ariel

    Ariel Staff Member

    Oh great. That looks pretty good! The last slash is missing from the darker image (I'm going to guess that's the silver cart) but that shouldn't effect printing very much at all.

    I can't wait to see what printing the first circuit is like now.
  13. Software doesn't play nice with 0.14 fw, "Print aborted. Printer firmware needs upgrade." Using ArC 0.15.1 and firmware 0.14 on Ubuntu. Printing from console:

    p LED_light.hex

    +Printing 'LED_light.hex'

    -File could not be opened: LED_light.hex

    +x: 9802 y: 0

    +Print complete. Enjoy your circuit!

    I've tried this with a hex generated by ArC and then the same hex with X and Y swapped, same message is returned.


    So backwards compatibility aside, if I use 0.15.1 fw with 0.15 ArC, the software and firmware function properly, but, as seen in the starter circuit picture I posted, I have vertical lines where nothing gets sprayed, causing high resistance/ discontinuity. I would assume nozzle issues, but the nozzle test had decent results.

    ~edit: LED_light is what I named the starter circuit, if there was any confusion
    Last edited: Dec 31, 2014
  14. Example of the vertical lines, a single pass of the starter circuit:
    StarterCircuitSinglePass.jpg
  15. Any new ideas?
  16. Trent Waddington

    Trent Waddington Staff Member

    I just fixed BothCartridges.hex for the 0.15 firmware. John reports it as working. Don't know if this will help.

    Attached Files:

  17. Johns

    Johns Staff Member

    Thanks Trent. That hex file will work with firmware 1.5 and above.
  18. Johns

    Johns Staff Member

  19. 2 runs of BothCartridgesNew.hex, both heated and the top one with cartridges swapped.

    BothCartridgesNew.jpg
  20. Johns

    Johns Staff Member

    Sorry AdamF, what do you mean the top one with the cartridges swapped? Looks like your top cartridge isn't working too well. You've primed the cartridge right? You should be able to compensate for the cartridge not firing all nozzles by changing the print_overlap setting. I would have another go printing the circuit with print_overlap set low, something like 31 and see what difference that makes.

Share This Page