Assembly help thread

Discussion in 'Community Support' started by Stumpi, Sep 3, 2014.

  1. Michael Reed

    Michael Reed Staff Member

    Hey Michael,

    I'm sure we're confusing someone with our names haha. And yes sure, what address would you like us to post it to?
  2. Haha I thought as much too. 6 Yarrabung Rd St Ives NSW 2075 please. Thanks very much for the help
  3. Michael Reed

    Michael Reed Staff Member

    That's all good - sorry for the hassle! I'll make sure they get sent out today - I'll just be out of the office most of today so they'll leave this afternoon (Brisbane, Australia time).

    Let me know if you want us to include anything else in the package you might find handy (we may also include some candy...).
  4. Package arrived yesterday and they fit snugly. Thanks again for the help (and candy)
    Ariel likes this.
  5. Hi all. I've been working through the assembly, and keeping notes on errata or other interesting bits. Below is my list so far, for whomever it may help. Overall I'm quite impressed with the work that's gone into this! Please take this info as constructive feedback, and not criticism at all.

    1. pg58 step 49: add "you don't need to press it down all the way" - as that's what the diagram shows, and if you try, the slight angle from the laser cut doesn't line up well with the other parts and it jams. Frustrating if you don't realize that you don't actually need to lay them all flat.
    2. pg58 step 51: CA-14 should be CA-13
    3. pg59 step 54: the M3-50 bolts that were holding the acrylic stack together ended up a bit bent from shipping; not unsalvageable but not ideal, either.
    4. pg60 step 58: CA-14 should be CA-16
    5. A couple of the pogo pins were ~0.5mm too low. It was easy to fix them by using the MDF wood packing panels as an alignment jig. Simply heated the solder and slid the pin down to hit the table, where the rest were sitting flush.
    6. Installing the pogo pin boards was *way* easier with the flat-flex removed, and also, installing them several steps later in the process.
    7. Assembling things under a bench ionizer to kill static electric charge (a 3M Model 960) - These are great for the static that you get from peeling the protective plastic/paper off the acrylic... keeps dust away! Of course I use it primarily for ESD control.
    8. pg63 step 72: Says M3-16, should be the M2 (I screwed up and drilled out the holes on CA-24 to fit M3, thinking it may have been melted plastic shrinking the holes. Oops! Still worked out though!)
    9. pg64 step 73: Says M3 square nuts, should be M2 nylock
    10. Most parts were not square on the transverse (cut) side. The laser was cutting at slight angle from vertical. This isn't the very slight trapezoid shape (cross section) that happens where the top is a tiny bit narrower than the bottom: / \. It has a parallelogram cross section / /, and it's at least one to two degrees off. The biggest detrimental effect was the roller bearings wouldn't sit square. They seem to roll ok, but it increases the friction a good bit.
    11. MF-13 and MF-15 needed to be shaved down in length for a good fit
    12. pg 102 step 22, pg 103 step 28: Instructions do not say to fold the small LED strips here, but the later diagrams show them folded under the plastic bit. See pg 153 step 27 below for final instructions that somewhat conflict here.
    13. pg 114 step 19, pg115 step 21: Instructions say M3x10, image says M3x16 - should be x10 I think
    14. pg 118 step 34: the 5mm steel rod doesn't fit in the coupler, too tight. Turns out one side of my coupler was a tiny bit tighter than the other. Flipping it around fixed the problem, although my calipers measured the rod and motor at both 5.00mm.... must have been tiny difference!
    15. pg 119, step 40: Doesn't mention YM-11 which is depicted as the next part
    16. pg 121 step 45: The bearings didn't fit on the 5mm rod. Ended up using a grinding wheel to slim down the rod to get a fit.
    17. pg 121 step 46: Should the toothed pulley be attached to the torque rod or free spinning? (I think this was addressed later and I forgot to note it...)
    18. pg 126 step 65: There is no note on orientation of fan cable
    19. pg 126 step 66: says M3x15, should be x16
    20. pg 141: regarding the clamps for the ends of the belts... they have nice little slots to feed the belt through but the directions don't make use of them!
    21. pg 148 step 7: mentions applying thermal tape to heatsinks. Mine already have 3M adhesive backing on them, and there are no included thermal tapes. Hopefully the 3M backing is a thermal transfer tape!
    22. pg 152 step 23: The cable from right-side fan (looking from rear of machine) to FET1 is about 1cm too short!
    23. pg 153 step 27: Regarding folding the LED strip: may conflict with pg 102 step 22 above. (I put mine in a different location entirely because why not! =)
    24. pg 157 step 44: The cable with the new DC jack (the one that required a new part because it has no flats) is orange/black, not red/black.
    25. pg 158 step 45: The cable on the power switch is yellow/blue not grey/grey
    26. pg 159 step 50: Software screenshots need updating. No big deal...
    27. pg 159 step 51: Could not get software to connect. Was able to use Arduino built-in serial console. It may be my port baud rate settings, haven't figured out yet. Still able to proceed with hardware diagnostics... Also noted that board has 0.12 firmware, so will have to update it with the newer that's out.
    28. pg 161 steps: One of the steppers isn't stepping! Upon investigation, found that the QFN chips on the two stepper driver boards are not fully soldered on, some of the pins were missed. Looks like it was done by hand, so that makes sense (have done before so I know the pain lol. Those buggers are small!!) Will fix em up and continue.
    Will post more here as I go, now that I've gotten back to the assembly. Can't wait to have it up and running!
  6. Ariel

    Ariel Staff Member

    Damn annoying about the stepper drivers. We test everything before sending them out, so I'm not sure how that slipped though. What motherboard number do you have?
  7. Motherboard v0.7.1 with a sticker that says 02-010, from printer batch 2, #87. Got em working! Drag soldering for the win. (One of them was missing one pin, but worked. The other was missing one or two pins, from three sides, and did not work.)

    While I've already set my stepper current using the previous version 0.12, I've noticed the stest command doesn't do anything in firmware 0.15.1
  8. Ariel

    Ariel Staff Member

    Neat-o. I'm not really that proficient at drag soldering myself. I'll take the next opportunity to practice. I have fixed a couple of these in the past by throwing them on a hot plate, but not with the headers already attached.

    God I love soldering porn.
  9. 5.2, Carriage Assembly, CA-02, note says:

    NOTE: THIS PART
    HAS A REPLACEMENT IN
    THE
    MISCELLANEOUS
    BOX - DO NOT USE THE
    ONE SHOWN IN RED IN
    THE TOP LEFT IMAGE -
    USE THE ONE FROM THE
    MISCELLANEOUS BOX.

    First, there is NO Miscellaneous Box, there is an Accessories Box, which does have some parts in it, but not that part.
    I spent several minutes looking though everything for a part that did not exist... only to use the part in the main set, disregarding the note. Is there STILL a reason not to use that part? or is it missing because the one in the main set has been fixed? My printer is fully assembled now, with the part the note said not to use.


    12.23, wow, the fan wire could not have been 5mm longer? The earlier directions did not mention which way to face the wires, I had to remount the fan to get just enough length to barely be able to plug it in.

    12.42, wrong colors and text, those are the Y axis motor colors, but not for the X axis, there is a red wire, on the bottom ...

    I could go on ...

    My first impression upon unpacking the box and starting to read the assembly docs was very positive.
    As we went though the assembly, finding several mistakes and omission, my impression lowered.
    Now that I see that most (all?) of the issues are well known and have been for a few months, I am even less impressed.

    I am still poking around forums and wikies to find information that should have been in the docs... not happy.

    I did do a dry run of the test print, after some software difficulties (errr...) it finally worked and looked correct.
    I have still to put the cartridges in and print it for real.

Share This Page